ROS軟路由論壇 ROSABC.com

 找回密碼
 會員注冊
查看: 21440|回復: 160
打印 上一主題 下一主題

[VPN虛擬私有網絡] [PPTP 應用實例] Router to Router 安全隧道實例 以下是一個使用

  [復制鏈接]
跳轉到指定樓層
樓主
發表于 2013-4-21 03:59:45 | 只看該作者 回帖獎勵 |倒序瀏覽 |閱讀模式
ROS軟路由論壇
PPTP 應用實例

Router to Router 安全隧道實例

以下是一個使用互聯網上的加密 PPTP 隧道連接兩個企業網局域網的例子:
游客,如果您要查看本帖隱藏內容請回復



在這個例子中有兩個不同地區辦公室的路由器,需要讓兩個辦公局域網的主機之間實現互訪:

-- [HomeOffice]

接口 LocalHomeOffice 10.150.2.254/24

接口 ToInternet 192.168.80.1/24

-- [RemoteOffice]

接口 ToInternet 192.168.81.1/24

接口 LocalRemoteOffice 10.150.1.254/24

每個路由器連接到當地的 ISP,任何一個路由器可以通過互聯網訪問到對端的路由器。

HomeOffice 配置

在 HomeOffice 端建立 PPTP 服務器,首先我們進入/ppp secret 目錄下添加客戶端賬號:


[admin@HomeOffice] ppp secret> add name=ex service=pptp password=123456 local-address=10.0.103.1 remote-address=10.0.103.2

[admin@HomeOffice] ppp secret> print detail
Flags: X - disabled
0 name="ex" service=pptp caller-id="" password="123456" profile=default local-address=10.0.103.1 remote-address=10.0.103.2 routes==""

[admin@HomeOffice] ppp secret>

Winbox 操作如下:



在 interface pptp-server server 目錄下,啟用 pptp 服務器:


[admin@HomeOffice] interface pptp-server server> set enabled=yes

[admin@HomeOffice] interface pptp-server server> print enabled: yes
mtu: 1460

mru: 1460 authentication: mschap2 default-profile: default

[admin@HomeOffice] interface pptp-server server>

Winbox 下配置進入 ppp 目錄下啟用 pptp server:



RemoteOffice 配置

在 RemoteOffice 路由器添加一個 PPTP 客戶:


[admin@RemoteOffice] interface pptp-client> add connect-to=192.168.80.1 user=ex \
\... password=123456 disabled=no
[admin@RemoteOffice] interface pptp-client> print Flags: X - disabled, R - running
0 R name="pptp-out1" mtu=1460 mru=1460 connect-to=192.168.80.1 user="ex" password="123456" profile=default add-default-route=no

[admin@RemoteOffice] interface pptp-client>

Winbox 在 interface 中添加 pptp-client



這樣,一個 PPTP 隧道就在路由器之間創建好了。這個隧道就像在 IP 地址為 10.0.103.1 及 10.0.103.2 的路 由器之間的三層點對點連接。

pptp 局域網的互訪

pptp 隧道建立完成后,僅是路由器間可以互訪,但兩個企業間的局域網需要通過設置路由完成連接



為了在 PPTP 隧道上互訪企業間本地網絡,需要添加以下路由:


[admin@HomeOffice] > ip route add dst-address=10.150.1.0/24 gateway=10.0.103.2


[admin@RemoteOffice] > ip route add dst-address=10.150.2.0/24 gateway=10.0.103.1

或者也可以在 PPTP 服務器(HomeOffice)上通過用戶配置的 routes 參數完成,RemoteOffice 還是需要在

/ip route 中配置路由:


[admin@HomeOffice] ppp secret> print detail
Flags: X - disabled
0 name="ex" service=pptp caller-id="" password="123456" profile=default local-address=10.0.103.1 remote-address=10.0.103.2 routes==""

[admin@HomeOffice] ppp secret> set 0 routes="10.150.1.0/24 10.0.103.2 1"
[admin@HomeOffice] ppp secret> print detail
Flags: X - disabled
0 name="ex" service=pptp caller-id="" password="123456" profile=default local-address=10.0.103.1 remote-address=10.0.103.2 routes="10.150.1.0/24 10.0.103.2 1"

[admin@HomeOffice] ppp secret>

目的路由:10.150.1.0/24 pptp 的網關:10.0.103.2

Distance 路徑: 1

Winbox 中修改 routes 參數
游客,如果您要查看本帖隱藏內容請回復



測試 PPTP 隧道連接:


[admin@RemoteOffice]> /ping 10.0.103.1
10.0.103.1 pong: ttl=255 time=3 ms

10.0.103.1 pong: ttl=255 time=3 ms
10.0.103.1 pong: ttl=255 time=3 ms ping interrupted
3 packets transmitted, 3 packets received, 0% packet loss round-trip min/avg/max = 3/3.0/3 ms

測試通過 PPTP 隧道到 LocalHomeOffice 接口的連接:


[admin@RemoteOffice]> /ping 10.150.2.254
10.150.2.254 pong: ttl=255 time=3 ms
10.150.2.254 pong: ttl=255 time=3 ms
10.150.2.254 pong: ttl=255 time=3 ms ping interrupted
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 3/3.0/3 ms

沙發
發表于 2013-5-28 12:05:18 | 只看該作者
ROS軟路由論壇
dfsfsfghdfgsgsgds
板凳
發表于 2013-5-31 16:51:40 | 只看該作者
希望能幫助到我··
地板
發表于 2013-6-26 00:36:45 | 只看該作者
WERWEWEFRQEWFQEWFDVFW
5
發表于 2013-6-26 10:00:48 | 只看該作者
see see see see what
6
發表于 2013-12-3 10:20:44 | 只看該作者
fjhkgl;'
jhjhjkhkjnkljk
7
發表于 2013-12-3 13:54:50 | 只看該作者
配置完成后,我們便可以通過 PPTP 或者 L2TP 連接 RouterOS 的 VPN 服務,在 windows 下可以通過 PPTP 的方式直接連 接 RouterOS 的 VPN 服務,但 L2TP 不行,因為 windows 要求 L2TP 進行 IPsec 的加密方式連接,這里我們可以通過修 改 windows 注冊表連接

L2TP 的 Windows 注冊表修改

配置完成后,我們便可以通過 PPTP 或者 L2TP 連接 RouterOS 的 VPN 服務,在 windows 下可以通過 PPTP 的方式直接連 接 RouterOS 的 VPN 服務,但 L2TP 不行,因為 windows 要求 L2TP 進行 IPsec 的加密方式連接,配置完成后,我們便可以通過 PPTP 或者 L2TP 連接 RouterOS 的 VPN 服務,在 windows 下可以通過 PPTP 的方式直接連 接 RouterOS 的 VPN 服務,但 L2TP 不行,因為 windows 要求 L2TP 進行 IPsec 的加密方式連接,這里我們可以通過修 改 windows 注冊表連接

L2TP 的 Windows 注冊表修改

這里我們可以通過修 改 windows 注冊表連接

L2TP 的 Windows 注冊表修改

8
發表于 2013-12-18 09:06:47 | 只看該作者
學習一下,感謝分享。
9
發表于 2014-5-31 18:46:20 | 只看該作者
來頂下,學習了
10
發表于 2014-6-12 15:49:23 | 只看該作者
單點不加遠程網關。拔入后經常一會就斷內網,但是VPN連接正常
您需要登錄后才可以回帖 登錄 | 會員注冊

本版積分規則

ROS教程版塊已全面開放,
即使是新注冊的初級會員也可閱讀全部內容。

不良信息舉報Q:2000617 點擊留言

不良信息舉報Q:2000617|Archiver|小黑屋|ROS軟路由論壇 ROSABC.com

GMT+8, 2020-7-8 01:02 , Processed in 0.218442 second(s), 21 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回復 返回頂部 返回列表
又黄又刺激的免费视频-又黄又免费的美女视频