ROS軟路由論壇 ROSABC.com

 找回密碼
 會員注冊
查看: 17204|回復: 100
打印 上一主題 下一主題

[VPN虛擬私有網絡] [通過 PPTP 隧道連接終端客戶] 下面的例子顯示了通過終端電

  [復制鏈接]
跳轉到指定樓層
樓主
 樓主| 發表于 2013-4-21 04:01:06 | 只看該作者 回帖獎勵 |倒序瀏覽 |閱讀模式
ROS軟路由論壇
通過 PPTP 隧道連接終端客戶

下面的例子顯示了通過終端電腦與遠程辦公網絡進行 PPTP 加密隧道通信,如外地出差的同時,通過筆記本電腦 連接會公司的網絡進行遠程信息管理和查詢
游客,如果您要查看本帖隱藏內容請回復



這個例子中的路由器:

-- [RemoteOffice]

接口 ToInternet 192.168.81.1/24

接口 Office 10.150.1.254/24

在 PPTP 服務器上設置用戶帳號:


[admin@RemoteOffice] ppp secret> add name=ex service=pptp password=123456 local-address=10.150.1.254 remote-address=10.150.1.2

[admin@RemoteOffice] ppp secret> print detail
Flags: X - disabled
0 name="ex" service=pptp caller-id="" password="123456" profile=default local-address=10.150.1.254 remote-address=10.150.1.2 routes==""

[admin@RemoteOffice] ppp secret>

啟用 pptp 服務:  


[admin@RemoteOffice] interface pptp-server server> set enabled=yes

[admin@RemoteOffice] interface pptp-server server> print enabled: yes
mtu: 1460 mru: 1460
authentication: mschap2 default-profile: default

[admin@RemoteOffice] interface pptp-server server>

在筆記本電腦訪問回公司后,需要訪問內部網絡資源,需要配置規則才能確保通常,有兩種方法: 局域網連接方法 1:代理 ARP 必須在'Office'接口上啟用,這樣可以通過代理 arp 訪問,但有個缺點是內網的DHCP 服務可能會受到影響:


[admin@RemoteOffice] interface ethernet> set Office arp=proxy-arp

[admin@RemoteOffice] interface ethernet> print
Flags: X - disabled, R - running
# NAME MTU MAC-ADDRESS ARP
0 R ToInternet 1500 00:30:4F:0B:7B:C1 enabled
1 R Office 1500 00:30:4F:06:62:12 proxy-arp

[admin@RemoteOffice] interface ethernet>

在 winbox 中進入 interface 目錄下,選擇 office 接口設置 arp 為 proxy-arp
游客,如果您要查看本帖隱藏內容請回復



局域網連接方法 2:通過 nat 設置 masquerade,規則要求對所有來訪數據進行偽裝,這樣保證內外網通過轉 換通信


[admin@RemoteOffice] /ip firewall nat> add chain=srcnat action=masquerade

[admin@RemoteOffice] /ip firewall nat> print
Flags: X - disabled, R - running
Flags: X - disabled, I - invalid, D - dynamic
0 chain=srcnat action=masquerade

[admin@RemoteOffice] interface ethernet>

在 winbox 中添加 masquerade 規則:



Windows 的 PPTP 設置

對 Windows NT,2000,98SE 以及 98 支持 PPTP 客戶。Windows 98SE,2000,以及 ME 包括 Windows 設置中的支 持或者自動安裝 PPTP。對 95,NT,及 98,安裝需要從 Microsoft 下載。很多 ISP 都制作了幫助頁面以幫助客戶進行 Windows PPTP 安裝。

PPTP (VPN)安裝的簡單說明及客戶設置 - Windows 98SE

如果 VPN(PPTP)套件已經安裝,選擇'Dial-up Networking' 和 'Create a new connection'。創建一個 VPN 的選項應 該選擇。如果沒有 VPN 選項,那么按照下面的安裝說明進行。當詢問 VPN 服務器主機名或 IP 地址時,輸入路由器的 IP 地 址。雙擊'new'圖標并輸入正確的用戶名和密碼(必須在路由器或用于認證的用戶數據庫中)。

連接的設置在選擇了'connect'按鈕后需要 9 秒鐘。建議把連接屬性進行編輯以便'NetBEUI', 'IPX/SPX compatible',及

'Log on to network'為未選擇的。連接的設置時間為在'connect'按鈕選擇后 2 秒鐘。

為了安裝 Windows 98SE 的 VPN 套件,從'Start'主目錄中選擇'Setting'。選擇'Control Panel',選擇'Add/Remove Program',選擇'Windows setup'標簽,選擇 'Communications'軟件安裝以及'Details'。在軟件列表的底部選擇'Virtual Private Networking'安裝。

故障分析

-- 我使用了防火墻但我不能建立 PPTP 建立

確定 TCP 連接到 1723 端口可以通過你的兩個站點。而且,TCP 協議 47 應該通過。

評分

參與人數 1A幣 +6 收起 理由
lxh123 + 6 贊贊贊

查看全部評分

沙發
發表于 2013-5-28 12:03:16 | 只看該作者
ROS軟路由論壇
sdsadsadasfasfsasad
板凳
發表于 2013-5-30 14:14:01 | 只看該作者
學習了, 不錯

點評

新人學習一下!  詳情 回復 發表于 2019-7-22 11:17
地板
發表于 2013-7-19 17:19:11 | 只看該作者
值得學習的東西
5
發表于 2013-8-8 03:21:58 | 只看該作者
謝謝 謝謝
6
發表于 2013-9-27 13:05:50 | 只看該作者
學習了, 不錯
學習了, 不錯
7
發表于 2013-10-1 23:48:37 | 只看該作者
..............................推推推
8
發表于 2013-12-2 16:05:47 | 只看該作者
學習一下,感謝分享。
9
發表于 2013-12-5 18:46:54 | 只看該作者
看下,學習一下
10
發表于 2013-12-23 17:15:52 | 只看該作者
學習一下,感謝分享。
您需要登錄后才可以回帖 登錄 | 會員注冊

本版積分規則

ROS教程版塊已全面開放,
即使是新注冊的初級會員也可閱讀全部內容。

不良信息舉報Q:2000617

不良信息舉報Q:2000617|Archiver|小黑屋|ROS軟路由論壇 ROSABC.com

GMT+8, 2020-7-14 01:01 , Processed in 0.167927 second(s), 22 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回復 返回頂部 返回列表
又黄又刺激的免费视频-又黄又免费的美女视频